We have implemented a fix for the intermittent issues affecting Google Drive and Google Docs while connected to Eduroam. Services are now operating normally.
We are continuing to work with our vendor to determine the underlying cause of the issue and help prevent it from happening again.
If you are still experiencing issues, please contact the Help Desk at help@humboldt.edu or 707-826-4357.
We appreciate your patience while we worked to resolve this issue.
Posted Sep 04, 2026 - 13:20 PDT
Identified
We have identified the cause of the intermittent issues affecting Google Drive and Google Docs while connected to Eduroam.
We have contacted our vendor and opened a support case with them to assist in resolving the issue. We are continuing to work toward a resolution and will provide additional updates as more information becomes available.
Posted Sep 04, 2026 - 10:17 PDT
Investigating
We are currently investigating reports of intermittent issues accessing Google Drive and Google Docs while connected to the Eduroam wireless network.
Folks may experience slow loading, connection errors, or difficulty opening and saving files in Google Drive and Docs.
ITS is investigating the issue and working to identify the cause. We will provide additional updates as more information becomes available.