Campus Solutions (Student Center and Faculty Center) Peoplesoft system going down for Maintenance tonight (9/11/26) 6-10pm

Incident Report for Cal Poly Humboldt System Status

Resolved

MP32.02 has been installed into Production Campus Solutions.
Posted Sep 13, 2026 - 13:22 PDT

Investigating

Maintenance Window tonight 6-10pm for CMS to install a necessary maintenance pack, MP32.02 for Financial Aid.
Posted Sep 11, 2026 - 07:50 PDT
This incident affected: Faculty Center/Student Center/PeopleSoft Campus Solutions.